Copyright 2014 ERCentertainment. All rights reserved

SledSimulator

Click here to edit subtitle

Forums

Post Reply
Forum Home > Bug reports > Sled simultaor dosent work on W8.1

Aidou
Member
Posts: 2

Hey so i tried to install it on my dell latitude 3340 8gb ram 130ssd. it dosent seem to work. at all . the graphiks is all bugged and sometimes the homescreen is just dark and i cant klick anything:(

--
October 7, 2014 at 5:00 AM Flag Quote & Reply

3r5k3n
Site Owner
Posts: 222
Windows 8.1 shouldn't be a issue because that's what I'm using
--

October 7, 2014 at 5:22 AM Flag Quote & Reply

SuedTree
Member
Posts: 13

I have the same problem on windows 8.1 actually, just a black screen on the menu :( 

October 7, 2014 at 6:27 AM Flag Quote & Reply

lilltejbz
Member
Posts: 78

i also have windows 8 and it works fine


October 7, 2014 at 9:09 AM Flag Quote & Reply

Tompa
Member
Posts: 9

am I realy the onely one that can't download the game ?


October 7, 2014 at 11:06 AM Flag Quote & Reply

dixxon
Member
Posts: 47

have you tryed redownloading and installing it to see if that does anything or the alternate links because on the old version i couldnt get it to work for a bit, idk why and then it jst started working after i redownloaded it

October 7, 2014 at 1:19 PM Flag Quote & Reply

Tompa
Member
Posts: 9

jepp several times and with different browsers.. :(


October 7, 2014 at 2:55 PM Flag Quote & Reply

SuedTree
Member
Posts: 13

I tried reinstalling several times, but had no luck :P I have the game installed on my main computer with windows 7 and it runs great :)

October 7, 2014 at 2:56 PM Flag Quote & Reply

Polaris600
Member
Posts: 1

Had the same problem black loading screen couldnt click anything. Just update your graphics software and it should work.

January 8, 2015 at 3:09 PM Flag Quote & Reply

You must login to post.

Oops! This site has expired.

If you are the site owner, please renew your premium subscription or contact support.